Changes between Version 1 and Version 2 of DebianPerlLocaleError


Ignore:
Timestamp:
05/19/07 16:44:57 (11 years ago)
Author:
sgk
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • DebianPerlLocaleError

    v1 v2  
    11= PerlがLocaleどうのと怒ったら = 
     2 
     3Debianのインストーラは良くできているんですが、ロケール関係がいまいちのようです。 
     4インストーラの中でロケールを適切に選んでいるにもかかわらず、ロケールデータベースが作成されていないことが度々あります。 
     5Perlを起動して気づきます。Perlを起動するたびに以下のようなエラーが出るようなら、この問題です。 
    26 
    37{{{ 
     
    1115}}} 
    1216 
    13 perlを起動する度にこんなエラーが出たら、ロケールデータベースの構築に失敗しています。 
    14 `apt-get upgrade`でアップデートするときや、インストールするときに失敗することがあるんです。 
    15 こういう問題に出くわしたら、以下のように操作すれば直ります。 
     17インストールや`apt-get upgrade`でもPerlが使われているので、このエラーメッセージをたくさん見かけることがあります。 
     18この問題は、以下のように操作すれば直ります。 
    1619 
    1720{{{ 
     
    2528 
    2629この画面、見たことありますね。 
    27 apt-get upgradeで見たかもしれませんね 
    28 でも、upgradeで処理したときは、どうやらエラーになっちゃうことが多いようなんです 
    29 そのあたり定かではありませんが 
     30インストーラでも表示されたはずです 
     31apt-get upgradeで見たかもしれません 
     32なぜインストーラでうまくいかなくて、手でやるとうまくいくのか、いまいち追求していません 
    3033 
    3134参考になりましたか?